Стандартные функции Excel

Больше
2 года 6 мес. назад - 2 года 6 мес. назад #38 от roman
roman создал тему: Стандартные функции Excel
Excel поддерживает множество стандартных математических функций (формул), с помощью которых можно работать с ячейками (таблицами) не погружаясь в язык программирования VBA. Стандартные функции Excel разделяются на следующие типы: арифметические, статистические, логические, текстовые, функции даты и времени. С помощью данных функций можно создавать сложные математические выражения и решать поставленные задачи.
В данной теме будут представлены примеры реализации математических выражений для решения конкретных задач.
Последнее редактирование: 2 года 6 мес. назад пользователем roman.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
2 года 6 мес. назад - 2 года 6 мес. назад #39 от roman
roman ответил в теме Стандартные функции Excel
Необходимо просуммировать в Excel первые N значений, которые находятся в столбце (или в строке). Рассмотрим как это можно выполнить стандартными средствами не привязываясь к наименованию ячеек.
=СУММ(ДВССЫЛ(АДРЕС(Строка;Столбец)):ДВССЫЛ(АДРЕС(Строка;Столбец)))
Строка – это числовой номер строки в Excel
Столбец – это числовой номер столбца в Excel

Например, необходимо просуммировать первые 10 значений, которые находятся в столбце А. Для этого в ячейке необходимо набрать следующую функцию:
=СУММ(ДВССЫЛ(АДРЕС(1;1)):ДВССЫЛ(АДРЕС(10;1)))
Достоинством данного метода является то, что можно автоматизировать процесс суммирования. Например, у Вас есть выборка данных за сутки, и Вам необходимо просуммировать данные за час и получить 24 значения. Данную задачу можно решить данным способом.
Последнее редактирование: 2 года 6 мес. назад пользователем roman.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Больше
1 год 3 мес. назад - 1 год 3 мес. назад #98 от roman
roman ответил в теме Стандартные функции Excel
Например, необходимо в столбце найти строку с определенным значением и скопировать данные с данной строки.
Для данной задачи можно воспользоваться следующей структурой:
=ДВССЫЛ(АДРЕС(ПОИСКПОЗ(Значение;Диапазон;0 или 1);Столбец))
В качестве примера:
=ДВССЫЛ("Лист1!"&АДРЕС(ПОИСКПОЗ(A2;Лист1!G:G;0);6))

ПОИСКПОЗ(A2;Лист1!G:G;0) - Функция ищет в столбце Лист1!G:G фразу A2. Функция возвращает порядковый номер (по строкам или столбцам). Отсчет номера начинается с первой позиции заданного диапазона.
АДРЕС(номер_строки, номер_столбца) - Функция возвращает текстовое значение в виде адреса ячейки.
ДВССЫЛ(ячейка) - Функция ДВССЫЛ возвращает ссылку, которая задана текстовой строкой.
Последнее редактирование: 1 год 3 мес. назад пользователем roman.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Время создания страницы: 0.090 секунд